Ticket #569 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

QListItemStyle->CssClass not supported

Reported by: VexedPanda Owned by: somebody
Priority: minor Milestone: 2.0.2 Stable
Component: QForms Version: 1.0.2 Legacy Maintenance
Keywords: Cc:

Attachments

ticket569.patch Download (9.7 KB) - added by vakopian 4 years ago.
Here is a patch against both HEAD and 1.1

Change History

Changed 4 years ago by alex94040

  • milestone changed from 1.0.3 Legacy Maintenance to 1.0.4 Legacy Maintenance

Changed 4 years ago by VexedPanda

So it looks like the issue is that QCheckBoxList and QRadioButtonList aren't calling the ListItem?'s GetAttributes? function and outputting them as part of rendering.

QListBoxBase shows the correct way of doing it.

Changed 4 years ago by VexedPanda

  • milestone changed from 1.0.4 Legacy Maintenance to 1.0 and Up

Changed 4 years ago by vakopian

Here is a patch against both HEAD and 1.1

Changed 4 years ago by alex94040

  • status changed from new to in_QA

Changed 4 years ago by alex94040

  • milestone changed from 1.0 and Up to 2.0.2 Stable

This patch doesn't work for 1.0 and 1.1 branches; I don't think it's worth it to back-port, so marking this for 2.0.2 only.

Changed 4 years ago by alex94040

  • status changed from in_QA to closed
  • resolution set to fixed

(In [992]) Fixes #569 (QListItemStyle->CssClass? not supported). Code by Vakopian + VexedPanda?.

Note: See TracTickets for help on using tickets.